# CVE-2018-25068: devent globalpom-utils FileResourceManagerProvider.java createTmpDir temp file

> Insecure temporary file creation in globalpom-utils allows remote attackers to read or modify sensitive data via race conditions.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jan 2023
- **Updated:** 10 Apr 2025
- **Also known as:** GHSA-jjvp-wfp8-rv69

## What is CVE-2018-25068?

CVE-2018-25068 is a medium-severity vulnerability in devent globalpom-utils, published on 6 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability has been found in devent globalpom-utils up to 4.5.0 and classified as critical. This vulnerability affects the function createTmpDir of the file globalpomutils-fileresources/src/main/java/com/anrisoftware/globalpom/fileresourcemanager/FileResourceManagerProvider.java. The manipulation leads to insecure temporary file. The attack can be initiated remotely. Upgrading to version 4.5.1 is able to address this issue. The patch is identified as 77a820bac2f68e662ce261ecb050c643bd7ee560. It is recommended to upgrade the affected component. VDB-217570 is the identifier assigned to this vulnerability.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-377 (DEPRECATED: Insecure Temporary File)

## Which versions are affected by CVE-2018-25068?

2 open source packages ship an affected version, including com.anrisoftware.globalpom:globalpomutils. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.anrisoftware.globalpom:globalpomutils` | Maven | All versions | 4.5.1 |
| `com.anrisoftware.globalpom:globalpomutils` | Maven | All versions | 4.5.1 |

Products: Globalpom-Utils Project Globalpom-Utils.

## How do I fix CVE-2018-25068?

Upgrade com.anrisoftware.globalpom:globalpomutils to 4.5.1 or later.

## Is CVE-2018-25068 being exploited?

There is no known exploitation of CVE-2018-25068 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25068 and fix it if it is affected.

What it is: CVE-2018-25068 is a medium-severity vulnerability in devent globalpom-utils, published on 6 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-25068 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.anrisoftware.globalpom:globalpomutils (Maven): affected all versions; fixed in 4.5.1
- com.anrisoftware.globalpom:globalpomutils (Maven): affected all versions; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25068/ (Markdown: https://insights.sbomify.com/CVE-2018-25068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25068
- OSV: https://osv.dev/vulnerability/CVE-2018-25068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25068/
Summaries are generated and may contain mistakes; the official description above is the record.
