{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-25070 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2018-25070 yet. Limit exposure of the affected software until one is available.","what":"CVE-2018-25070 is a medium-severity vulnerability in polterguy Phosphorus Five, published on 7 Jan 2023."},"fix_prompt":"Check this codebase for CVE-2018-25070 and fix it if it is affected.\n\nWhat it is: CVE-2018-25070 is a medium-severity vulnerability in polterguy Phosphorus Five, published on 7 Jan 2023. \nExploitation: There is no known exploitation of CVE-2018-25070 in the wild and no public exploit code.\n\nAffected product: polterguy Phosphorus Five. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-25070/ (Markdown: https://insights.sbomify.com/CVE-2018-25070/index.md)","id":"CVE-2018-25070","markdown":"https://insights.sbomify.com/CVE-2018-25070/index.md","name":"CVE-2018-25070","record":{"aliases":["GHSA-mwhp-pcvh-pcfp"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"phosphorus_five","vendor":"aista"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A vulnerability has been found in polterguy Phosphorus Five up to 8.2 and classified as critical. This vulnerability affects the function csv.Read of the file plugins/extras/p5.mysql/NonQuery.cs of the component CSV Import. The manipulation leads to sql injection. Upgrading to version 8.3 is able to address this issue. The patch is identified as c179a3d0703db55cfe0cb939b89593f2e7a87246. It is recommended to upgrade the affected component. VDB-217606 is the identifier assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"polterguy Phosphorus Five CSV Import NonQuery.cs csv.Read sql injection","id":"CVE-2018-25070","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2018"},"n_packages":0,"n_references":4,"next":{"headline":"roxlukas LMeve proxy.php insert_log sql injection","id":"CVE-2018-25071"},"packages":[],"prev":{"headline":"Netis Netcore Router hard-coded password","id":"CVE-2018-25069"},"products":["Phosphorus Five"],"published":"2023-01-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-09","vendors":["polterguy"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2018-25070/"}