# CVE-2018-25071: roxlukas LMeve proxy.php insert_log sql injection


- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 7 Jan 2023
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-rqjj-7ph3-x9gc

## What is CVE-2018-25071?

CVE-2018-25071 is a medium-severity vulnerability in roxlukas LMeve, published on 7 Jan 2023. 

### Official description

A vulnerability was found in roxlukas LMeve up to 0.1.58. It has been rated as critical. Affected by this issue is the function insert_log of the file wwwroot/ccpwgl/proxy.php. The manipulation of the argument fetch leads to sql injection. Upgrading to version 0.1.59-beta is able to address this issue. The patch is identified as c25ff7fe83a2cda1fcb365b182365adc3ffae332. It is recommended to upgrade the affected component. VDB-217610 is the identifier assigned to this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2018-25071?

It affects 1 product.


Products: Roxlukas Lmeve.

## How do I fix CVE-2018-25071?

No fix has been published for CVE-2018-25071 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-25071 being exploited?

There is no known exploitation of CVE-2018-25071 in the wild and no public exploit code.

## Other vulnerabilities in roxlukas LMeve

- [CVE-2021-4246](https://insights.sbomify.com/CVE-2021-4246/): roxlukas LMeve Login Page sql injection (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25071 and fix it if it is affected.

What it is: CVE-2018-25071 is a medium-severity vulnerability in roxlukas LMeve, published on 7 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2018-25071 in the wild and no public exploit code.

Affected product: roxlukas LMeve. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25071/ (Markdown: https://insights.sbomify.com/CVE-2018-25071/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25071
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25071
- OSV: https://osv.dev/vulnerability/CVE-2018-25071

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25071/
Summaries are generated and may contain mistakes; the official description above is the record.
