# CVE-2018-25077: melnaron mel-spintax spintax.js redos

> Attackers can cause denial of service in mel-spintax by providing input that triggers inefficient regular expression complexity.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jan 2023
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-qjm7-55vv-3c5f

## What is CVE-2018-25077?

CVE-2018-25077 is a low-severity denial of service vulnerability in melnaron mel-spintax, published on 18 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in melnaron mel-spintax. It has been rated as problematic. Affected by this issue is some unknown functionality of the file lib/spintax.js. The manipulation of the argument text leads to inefficient regular expression complexity. The name of the patch is 37767617846e27b87b63004e30216e8f919637d3. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-218456.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2018-25077?

2 open source packages ship an affected version, including mel-spintax. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mel-spintax` | npm | All versions | 1.0.3 |
| `mel-spintax` | npm | All versions | 1.0.3 |

Products: Mel-Spintax Project Mel-Spintax.

## How do I fix CVE-2018-25077?

Upgrade mel-spintax to 1.0.3 or later.

## Is CVE-2018-25077 being exploited?

There is no known exploitation of CVE-2018-25077 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25077 and fix it if it is affected.

What it is: CVE-2018-25077 is a low-severity denial of service vulnerability in melnaron mel-spintax, published on 18 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-25077 in the wild and no public exploit code.

Affected packages and fixed versions:
- mel-spintax (npm): affected all versions; fixed in 1.0.3
- mel-spintax (npm): affected all versions; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25077/ (Markdown: https://insights.sbomify.com/CVE-2018-25077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25077
- OSV: https://osv.dev/vulnerability/CVE-2018-25077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25077/
Summaries are generated and may contain mistakes; the official description above is the record.
