# CVE-2018-25079: Segmentio is-url index.js redos


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 4 Feb 2023
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-p9w8-2mpq-49h9

## What is CVE-2018-25079?

CVE-2018-25079 is a medium-severity vulnerability in Segmentio is-url, published on 4 Feb 2023. 

### Official description

A vulnerability was found in Segmentio is-url up to 1.2.2. It has been rated as problematic. Affected by this issue is some unknown functionality of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. Upgrading to version 1.2.3 is able to address this issue. The patch is identified as 149550935c63a98c11f27f694a7c4a9479e53794. It is recommended to upgrade the affected component. VDB-220058 is the identifier assigned to this vulnerability.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2018-25079?

2 open source packages ship an affected version, including is-url. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `is-url` | npm | All versions | 1.2.3 |
| `is-url` | npm | All versions | 1.2.3 |

Products: Segment Is-Url.

## How do I fix CVE-2018-25079?

Upgrade is-url to 1.2.3 or later.

## Is CVE-2018-25079 being exploited?

There is no known exploitation of CVE-2018-25079 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25079 and fix it if it is affected.

What it is: CVE-2018-25079 is a medium-severity vulnerability in Segmentio is-url, published on 4 Feb 2023. 
Exploitation: There is no known exploitation of CVE-2018-25079 in the wild and no public exploit code.

Affected packages and fixed versions:
- is-url (npm): affected all versions; fixed in 1.2.3
- is-url (npm): affected all versions; fixed in 1.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25079/ (Markdown: https://insights.sbomify.com/CVE-2018-25079/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25079
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25079
- OSV: https://osv.dev/vulnerability/CVE-2018-25079

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25079/
Summaries are generated and may contain mistakes; the official description above is the record.
