{"answers":{"affected":"2 open source packages ship an affected version, including mobiledetect/mobiledetectlib. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-25080 in the wild and no public exploit code.","fix":"Upgrade mobiledetect/mobiledetectlib to 2.8.32 or later.","what":"CVE-2018-25080 is a low-severity cross-site scripting vulnerability in MobileDetect, published on 4 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-25080 and fix it if it is affected.\n\nWhat it is: CVE-2018-25080 is a low-severity cross-site scripting vulnerability in MobileDetect, published on 4 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-25080 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mobiledetect/mobiledetectlib (Packagist): affected all versions; fixed in 2.8.32\n- mobiledetect/mobiledetectlib (Packagist): affected all versions; fixed in 2.8.32\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-25080/ (Markdown: https://insights.sbomify.com/CVE-2018-25080/index.md)","id":"CVE-2018-25080","markdown":"https://insights.sbomify.com/CVE-2018-25080/index.md","name":"CVE-2018-25080","record":{"aliases":["CLSA-2026-1790868391","GHSA-r77c-qv68-j3pp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP MobileDetect library","requires_auth":"low_privilege","summary":"Cross-site scripting in the example script allows remote attackers to inject malicious scripts via the PHP_SELF variable.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"mobiledetect","vendor":"mobiledetect"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, has been found in MobileDetect 2.8.31. This issue affects the function initLayoutType of the file examples/session_example.php of the component Example. The manipulation of the argument $_SERVER['PHP_SELF'] leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.8.32 is able to address this issue. The identifier of the patch is 31818a441b095bdc4838602dbb17b8377d1e5cce. It is recommended to upgrade the affected component. The identifier VDB-220061 was assigned to this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2025-12-03","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-12-03","kind":"exploitdb","ref":"52454","stars":null,"title":"MobileDetect 2.8.31 - Cross-Site Scripting (XSS)"}],"tier":"poc_unverified"},"has_fix":true,"headline":"MobileDetect Example session_example.php initLayoutType cross site scripting","id":"CVE-2018-25080","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":5,"next":{"headline":"Information disclosure in n/a","id":"CVE-2018-25081"},"packages":[{"ecosystem":"Packagist","fixed":["2.8.32"],"introduced":["0"],"last_affected":[],"package":"mobiledetect/mobiledetectlib","purl":null,"source":"GHSA-r77c-qv68-j3pp"},{"ecosystem":"Packagist","fixed":["2.8.32"],"introduced":["0"],"last_affected":[],"package":"mobiledetect/mobiledetectlib","purl":"pkg:composer/mobiledetect/mobiledetectlib","source":"GHSA-r77c-qv68-j3pp"}],"prev":{"headline":"Segmentio is-url index.js redos","id":"CVE-2018-25079"},"products":["MobileDetect"],"published":"2023-02-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-04-16","vendors":["n/a"]},"summary":"Cross-site scripting in the example script allows remote attackers to inject malicious scripts via the PHP_SELF variable.","url":"https://insights.sbomify.com/CVE-2018-25080/"}