# CVE-2018-25082: zwczou WeChat SDK Python to_xml xml external entity reference

> Remote attackers can exploit XML external entity injection in the WeChat SDK Python library to read sensitive data or cause denial of service.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Mar 2023
- **Updated:** 26 Feb 2025
- **Also known as:** GHSA-h384-ph77-3699, PYSEC-2026-572

## What is CVE-2018-25082?

CVE-2018-25082 is a medium-severity vulnerability in zwczou WeChat SDK Python, published on 21 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in zwczou WeChat SDK Python 0.3.0 and classified as critical. This issue affects the function validate/to_xml. The manipulation leads to xml external entity reference. The attack may be initiated remotely. Upgrading to version 0.5.5 is able to address this issue. The patch is named e54abadc777715b6dcb545c13214d1dea63df6c9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-223403.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2018-25082?

3 open source packages ship an affected version, including weixin-python. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weixin-python` | PyPI | All versions | 0.5.5 |
| `weixin-python` | PyPI | All versions | 0.5.5 |
| `weixin-python` | PyPI | All versions | 0.5.5 |

Products: Wechat Sdk Python Project Wechat Sdk Python.

## How do I fix CVE-2018-25082?

Upgrade weixin-python to 0.5.5 or later.

## Is CVE-2018-25082 being exploited?

There is no known exploitation of CVE-2018-25082 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25082 and fix it if it is affected.

What it is: CVE-2018-25082 is a medium-severity vulnerability in zwczou WeChat SDK Python, published on 21 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-25082 in the wild and no public exploit code.

Affected packages and fixed versions:
- weixin-python (PyPI): affected all versions; fixed in 0.5.5
- weixin-python (PyPI): affected all versions; fixed in 0.5.5
- weixin-python (PyPI): affected all versions; fixed in 0.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25082/ (Markdown: https://insights.sbomify.com/CVE-2018-25082/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25082
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25082
- OSV: https://osv.dev/vulnerability/CVE-2018-25082

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25082/
Summaries are generated and may contain mistakes; the official description above is the record.
