# CVE-2018-25083: pullit vulnerable to command injection

> Attackers can execute arbitrary OS commands via eval on Git branch names in the pullit Node.js package.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2023
- **Updated:** 24 Feb 2025
- **Also known as:** GHSA-8px5-63x9-5c7p

## What is CVE-2018-25083?

CVE-2018-25083 is a critical command injection vulnerability in n/a, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The pullit package before 1.4.0 for Node.js allows OS Command Injection because eval is used on an attacker-supplied Git branch name.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2018-25083?

2 open source packages ship an affected version, including pullit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pullit` | npm | All versions | 1.4.0 |
| `pullit` | npm | All versions | 1.4.0 |

Products: Pull It Project Pull It.

## How do I fix CVE-2018-25083?

Upgrade pullit to 1.4.0 or later.

## Is CVE-2018-25083 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-25083 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25083 and fix it if it is affected.

What it is: CVE-2018-25083 is a critical command injection vulnerability in n/a, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-25083 exists.

Affected packages and fixed versions:
- pullit (npm): affected all versions; fixed in 1.4.0
- pullit (npm): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25083/ (Markdown: https://insights.sbomify.com/CVE-2018-25083/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25083
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25083
- OSV: https://osv.dev/vulnerability/CVE-2018-25083

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25083/
Summaries are generated and may contain mistakes; the official description above is the record.
