{"answers":{"affected":"3 open source packages ship an affected version, including postgraas-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-25088 in the wild and no public exploit code.","fix":"Upgrade postgraas-server to 2.0.0 or later.","what":"CVE-2018-25088 is a medium-severity SQL injection vulnerability in Blue Yonder postgraas_server, published on 18 Jul 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-25088 and fix it if it is affected.\n\nWhat it is: CVE-2018-25088 is a medium-severity SQL injection vulnerability in Blue Yonder postgraas_server, published on 18 Jul 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-25088 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgraas-server (PyPI): affected all versions; fixed in 2.0.0\n- postgraas-server (PyPI): affected all versions; fixed in 2.0.0\n- postgraas-server (PyPI): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-25088/ (Markdown: https://insights.sbomify.com/CVE-2018-25088/index.md)","id":"CVE-2018-25088","markdown":"https://insights.sbomify.com/CVE-2018-25088/index.md","name":"CVE-2018-25088","record":{"aliases":["GHSA-vghm-8cjp-hjw6","PYSEC-2026-460"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Blue Yonder postgraas_server","requires_auth":"low_privilege","summary":"An attacker with permissions can execute arbitrary SQL commands via the create_postgres_db function in Blue Yonder postgraas_server.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"postgraas_server","vendor":"blueyonder"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A vulnerability, which was classified as critical, was found in Blue Yonder postgraas_server up to 2.0.0b2. Affected is the function _create_pg_connection/create_postgres_db of the file postgraas_server/backends/postgres_cluster/postgres_cluster_driver.py of the component PostgreSQL Backend Handler. The manipulation leads to sql injection. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 7cd8d016edc74a78af0d81c948bfafbcc93c937c. It is recommended to upgrade the affected component. VDB-234246 is the identifier assigned to this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Blue Yonder postgraas_server PostgreSQL Backend postgres_cluster_driver.py create_postgres_db sql injection","id":"CVE-2018-25088","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2018"},"n_packages":3,"n_references":4,"next":{"headline":"glb Meetup Tag Extension Link Attribute reverse tabnabbing","id":"CVE-2018-25089"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"postgraas-server","purl":null,"source":"GHSA-vghm-8cjp-hjw6"},{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"postgraas-server","purl":"pkg:pypi/postgraas-server","source":"GHSA-vghm-8cjp-hjw6"},{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"postgraas-server","purl":"pkg:pypi/postgraas-server","source":"PYSEC-2026-460"}],"prev":{"headline":"Arborator Server project.cgi start denial of service","id":"CVE-2018-25087"},"products":["postgraas_server"],"published":"2023-07-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Blue Yonder"]},"summary":"An attacker with permissions can execute arbitrary SQL commands via the create_postgres_db function in Blue Yonder postgraas_server.","url":"https://insights.sbomify.com/CVE-2018-25088/"}