CVE-2018-25104 CoinGate Plugin Payment callback.php postProcess logic error

Medium 5.3 Published Updated

Attackers can exploit a logic error in the payment callback to bypass security checks and manipulate transaction states in PrestaShop.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2018-25104?

CVE-2018-25104 is a medium-severity vulnerability in CoinGate Plugin, published on 17 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in CoinGate Plugin up to 1.2.7 on PrestaShop. It has been rated as problematic. Affected by this issue is the function postProcess of the file modules/coingate/controllers/front/callback.php of the component Payment Handler. The manipulation leads to business logic errors. The attack may be launched remotely. Upgrading to version 1.2.8 is able to address this issue. The patch is identified as 0a3097db0aec7c5d66686c142c6abaa1e126ca16. It is recommended to upgrade the affected component.

Weakness: CWE-840

Which versions are affected by CVE-2018-25104?

How do I fix CVE-2018-25104?

No fix has been published for CVE-2018-25104 yet. Limit exposure of the affected software until one is available.

Is CVE-2018-25104 being exploited?

There is no known exploitation of CVE-2018-25104 in the wild and no public exploit code.

Sources

Also known as GHSA-wrfv-4288-95xq.

Is CVE-2018-25104 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free