{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2018-25104 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2018-25104 yet. Limit exposure of the affected software until one is available.","what":"CVE-2018-25104 is a medium-severity vulnerability in CoinGate Plugin, published on 17 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-25104 and fix it if it is affected.\n\nWhat it is: CVE-2018-25104 is a medium-severity vulnerability in CoinGate Plugin, published on 17 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-25104 in the wild and no public exploit code.\n\nAffected product: CoinGate Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-25104/ (Markdown: https://insights.sbomify.com/CVE-2018-25104/index.md)","id":"CVE-2018-25104","markdown":"https://insights.sbomify.com/CVE-2018-25104/index.md","name":"CVE-2018-25104","record":{"aliases":["GHSA-wrfv-4288-95xq"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PrestaShop payment plugin","requires_auth":"low_privilege","summary":"Attackers can exploit a logic error in the payment callback to bypass security checks and manipulate transaction states in PrestaShop.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-840","name":null}],"description":"A vulnerability was found in CoinGate Plugin up to 1.2.7 on PrestaShop. It has been rated as problematic. Affected by this issue is the function postProcess of the file modules/coingate/controllers/front/callback.php of the component Payment Handler. The manipulation leads to business logic errors. The attack may be launched remotely. Upgrading to version 1.2.8 is able to address this issue. The patch is identified as 0a3097db0aec7c5d66686c142c6abaa1e126ca16. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"CoinGate Plugin Payment callback.php postProcess logic error","id":"CVE-2018-25104","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"business_logic","year":"2018"},"n_packages":0,"n_references":4,"next":{"headline":"File Manager \u003c= 3.0 - Unauthenticated Arbitrary File Upload/Download","id":"CVE-2018-25105"},"packages":[],"prev":{"headline":"Use-after-free vulnerabilities in lighttpd \u003c= 1.4.50","id":"CVE-2018-25103"},"products":["CoinGate Plugin"],"published":"2024-10-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-17","vendors":["n/a"]},"summary":"Attackers can exploit a logic error in the payment callback to bypass security checks and manipulate transaction states in PrestaShop.","url":"https://insights.sbomify.com/CVE-2018-25104/"}