# CVE-2018-25104: CoinGate Plugin Payment callback.php postProcess logic error

> Attackers can exploit a logic error in the payment callback to bypass security checks and manipulate transaction states in PrestaShop.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Oct 2024
- **Updated:** 17 Oct 2024
- **Also known as:** GHSA-wrfv-4288-95xq

## What is CVE-2018-25104?

CVE-2018-25104 is a medium-severity vulnerability in CoinGate Plugin, published on 17 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in CoinGate Plugin up to 1.2.7 on PrestaShop. It has been rated as problematic. Affected by this issue is the function postProcess of the file modules/coingate/controllers/front/callback.php of the component Payment Handler. The manipulation leads to business logic errors. The attack may be launched remotely. Upgrading to version 1.2.8 is able to address this issue. The patch is identified as 0a3097db0aec7c5d66686c142c6abaa1e126ca16. It is recommended to upgrade the affected component.

Weakness: CWE-840

## Which versions are affected by CVE-2018-25104?


## How do I fix CVE-2018-25104?

No fix has been published for CVE-2018-25104 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-25104 being exploited?

There is no known exploitation of CVE-2018-25104 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25104 and fix it if it is affected.

What it is: CVE-2018-25104 is a medium-severity vulnerability in CoinGate Plugin, published on 17 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-25104 in the wild and no public exploit code.

Affected product: CoinGate Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25104/ (Markdown: https://insights.sbomify.com/CVE-2018-25104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25104
- OSV: https://osv.dev/vulnerability/CVE-2018-25104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25104/
Summaries are generated and may contain mistakes; the official description above is the record.
