{"answers":{"affected":"2 open source packages ship an affected version, including fastify. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3711 in the wild and no public exploit code.","fix":"Upgrade fastify to 0.38.0 or later.","what":"CVE-2018-3711 is a high-severity denial of service vulnerability in HackerOne fastify node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-3711 and fix it if it is affected.\n\nWhat it is: CVE-2018-3711 is a high-severity denial of service vulnerability in HackerOne fastify node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-3711 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fastify (npm): affected all versions; fixed in 0.38.0\n- fastify (npm): affected all versions; fixed in 0.38.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3711/ (Markdown: https://insights.sbomify.com/CVE-2018-3711/index.md)","id":"CVE-2018-3711","markdown":"https://insights.sbomify.com/CVE-2018-3711/index.md","name":"CVE-2018-3711","record":{"aliases":["GHSA-mq6c-fh97-4gwv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Fastify Node module","requires_auth":"none","summary":"An attacker can cause a denial of service in Fastify by sending a large JSON payload, requiring an upgrade to the library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"fastify","vendor":"fastify"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Fastify node module before 0.38.0 is vulnerable to a denial-of-service attack by sending a request with \"Content-Type: application/json\" and a very large payload.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service vulnerability with large JSON payloads in fastify","id":"CVE-2018-3711","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Directory Traversal in serve","id":"CVE-2018-3712"},"packages":[{"ecosystem":"npm","fixed":["0.38.0"],"introduced":["0"],"last_affected":[],"package":"fastify","purl":null,"source":"GHSA-mq6c-fh97-4gwv"},{"ecosystem":"npm","fixed":["0.38.0"],"introduced":["0"],"last_affected":[],"package":"fastify","purl":"pkg:npm/fastify","source":"GHSA-mq6c-fh97-4gwv"}],"prev":{"headline":"Path traversal in GitLab Community and Enterprise Editions","id":"CVE-2018-3710"},"products":["fastify node module"],"published":"2018-06-07","related":[{"cvss_score":8.1,"headline":"fastify vulnerable to request body replacement via an async validation result collision","id":"CVE-2026-84504","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"fastify vulnerable to authentication bypass via malformed URLs reaching encapsulated not-found handlers","id":"CVE-2026-76169","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"fastify vulnerable to header validation bypass via incomplete schema case normalization","id":"CVE-2026-84428","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"fastify vulnerable to request validation bypass via skipped boolean false schemas","id":"CVE-2026-84469","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"fastify vulnerable to Body Schema Validation Bypass via Leading Space in Content-Type Header","id":"CVE-2026-33806","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":7.5,"headline":"Fastify's Content-Type header tab character allows body validation bypass","id":"CVE-2026-25223","kev_date_added":null,"published":"2026-02-03"},{"cvss_score":7.5,"headline":"Fastify vulnerable to invalid content-type parsing, which could lead to validation bypass","id":"CVE-2025-32442","kev_date_added":null,"published":"2025-04-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"An attacker can cause a denial of service in Fastify by sending a large JSON payload, requiring an upgrade to the library.","url":"https://insights.sbomify.com/CVE-2018-3711/"}