# CVE-2018-3711: Denial of Service vulnerability with large JSON payloads in fastify

> An attacker can cause a denial of service in Fastify by sending a large JSON payload, requiring an upgrade to the library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-mq6c-fh97-4gwv

## What is CVE-2018-3711?

CVE-2018-3711 is a high-severity denial of service vulnerability in HackerOne fastify node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fastify node module before 0.38.0 is vulnerable to a denial-of-service attack by sending a request with "Content-Type: application/json" and a very large payload.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2018-3711?

2 open source packages ship an affected version, including fastify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastify` | npm | All versions | 0.38.0 |
| `fastify` | npm | All versions | 0.38.0 |

Products: Fastify Fastify.

## How do I fix CVE-2018-3711?

Upgrade fastify to 0.38.0 or later.

## Is CVE-2018-3711 being exploited?

There is no known exploitation of CVE-2018-3711 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne fastify node module

- [CVE-2026-84504](https://insights.sbomify.com/CVE-2026-84504/): fastify vulnerable to request body replacement via an async validation result collision (high 8.1)
- [CVE-2026-76169](https://insights.sbomify.com/CVE-2026-76169/): fastify vulnerable to authentication bypass via malformed URLs reaching encapsulated not-found handlers (high 7.5)
- [CVE-2026-84428](https://insights.sbomify.com/CVE-2026-84428/): fastify vulnerable to header validation bypass via incomplete schema case normalization (high 7.5)
- [CVE-2026-84469](https://insights.sbomify.com/CVE-2026-84469/): fastify vulnerable to request validation bypass via skipped boolean false schemas (high 7.5)
- [CVE-2026-33806](https://insights.sbomify.com/CVE-2026-33806/): fastify vulnerable to Body Schema Validation Bypass via Leading Space in Content-Type Header (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3711 and fix it if it is affected.

What it is: CVE-2018-3711 is a high-severity denial of service vulnerability in HackerOne fastify node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3711 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastify (npm): affected all versions; fixed in 0.38.0
- fastify (npm): affected all versions; fixed in 0.38.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3711/ (Markdown: https://insights.sbomify.com/CVE-2018-3711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3711
- OSV: https://osv.dev/vulnerability/CVE-2018-3711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3711/
Summaries are generated and may contain mistakes; the official description above is the record.
