{"answers":{"affected":"2 open source packages ship an affected version, including serve. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3712 in the wild and no public exploit code.","fix":"Upgrade serve to 6.4.9 or later.","what":"CVE-2018-3712 is a medium-severity path traversal vulnerability in HackerOne serve node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-3712 and fix it if it is affected.\n\nWhat it is: CVE-2018-3712 is a medium-severity path traversal vulnerability in HackerOne serve node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-3712 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- serve (npm): affected all versions; fixed in 6.4.9\n- serve (npm): affected all versions; fixed in 6.4.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3712/ (Markdown: https://insights.sbomify.com/CVE-2018-3712/index.md)","id":"CVE-2018-3712","markdown":"https://insights.sbomify.com/CVE-2018-3712/index.md","name":"CVE-2018-3712","record":{"aliases":["GHSA-q2qh-cgc2-qhr3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js serve module","requires_auth":"low_privilege","summary":"A path traversal vulnerability in the serve Node.js module allows attackers to read arbitrary files from the server filesystem.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"serve","vendor":"zeit"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"serve node module before 6.4.9 suffers from a Path Traversal vulnerability due to not handling %2e (.) and %2f (/) and allowing them in paths, which allows a malicious user to view the contents of any directory with known path.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Directory Traversal in serve","id":"CVE-2018-3712","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Path Traversal in angular-http-server","id":"CVE-2018-3713"},"packages":[{"ecosystem":"npm","fixed":["6.4.9"],"introduced":["0"],"last_affected":[],"package":"serve","purl":null,"source":"GHSA-q2qh-cgc2-qhr3"},{"ecosystem":"npm","fixed":["6.4.9"],"introduced":["0"],"last_affected":[],"package":"serve","purl":"pkg:npm/serve","source":"GHSA-q2qh-cgc2-qhr3"}],"prev":{"headline":"Denial of Service vulnerability with large JSON payloads in fastify","id":"CVE-2018-3711"},"products":["serve node module"],"published":"2018-06-07","related":[{"cvss_score":7.5,"headline":"Path Traversal in serve","id":"CVE-2019-5415","kev_date_added":null,"published":"2019-03-17"},{"cvss_score":7.5,"headline":"Directory Traversal in serve","id":"CVE-2019-5417","kev_date_added":null,"published":"2019-03-17"},{"cvss_score":5.3,"headline":"vercel/serve allows access to restricted files if filename is URL encoded.","id":"CVE-2018-3718","kev_date_added":null,"published":"2018-06-07"},{"cvss_score":5.3,"headline":"Information Exposure on Case Insensitive File Systems in serve","id":"CVE-2018-3809","kev_date_added":null,"published":"2018-06-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"A path traversal vulnerability in the serve Node.js module allows attackers to read arbitrary files from the server filesystem.","url":"https://insights.sbomify.com/CVE-2018-3712/"}