# CVE-2018-3712: Directory Traversal in serve

> A path traversal vulnerability in the serve Node.js module allows attackers to read arbitrary files from the server filesystem.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-q2qh-cgc2-qhr3

## What is CVE-2018-3712?

CVE-2018-3712 is a medium-severity path traversal vulnerability in HackerOne serve node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

serve node module before 6.4.9 suffers from a Path Traversal vulnerability due to not handling %2e (.) and %2f (/) and allowing them in paths, which allows a malicious user to view the contents of any directory with known path.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-3712?

2 open source packages ship an affected version, including serve. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `serve` | npm | All versions | 6.4.9 |
| `serve` | npm | All versions | 6.4.9 |

Products: Zeit Serve.

## How do I fix CVE-2018-3712?

Upgrade serve to 6.4.9 or later.

## Is CVE-2018-3712 being exploited?

There is no known exploitation of CVE-2018-3712 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne serve node module

- [CVE-2019-5415](https://insights.sbomify.com/CVE-2019-5415/): Path Traversal in serve (high 7.5)
- [CVE-2019-5417](https://insights.sbomify.com/CVE-2019-5417/): Directory Traversal in serve (high 7.5)
- [CVE-2018-3718](https://insights.sbomify.com/CVE-2018-3718/): vercel/serve allows access to restricted files if filename is URL encoded. (medium 5.3)
- [CVE-2018-3809](https://insights.sbomify.com/CVE-2018-3809/): Information Exposure on Case Insensitive File Systems in serve (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3712 and fix it if it is affected.

What it is: CVE-2018-3712 is a medium-severity path traversal vulnerability in HackerOne serve node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3712 in the wild and no public exploit code.

Affected packages and fixed versions:
- serve (npm): affected all versions; fixed in 6.4.9
- serve (npm): affected all versions; fixed in 6.4.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3712/ (Markdown: https://insights.sbomify.com/CVE-2018-3712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3712
- OSV: https://osv.dev/vulnerability/CVE-2018-3712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3712/
Summaries are generated and may contain mistakes; the official description above is the record.
