# CVE-2018-3713: Path Traversal in angular-http-server

> Attackers can read arbitrary files on the server via path traversal in the angular-http-server Node.js module.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-4rvg-955w-h68q

## What is CVE-2018-3713?

CVE-2018-3713 is a medium-severity path traversal vulnerability in HackerOne angular-http-server node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

angular-http-server node module suffers from a Path Traversal vulnerability due to lack of validation of possibleFilename, which allows a malicious user to read content of any file with known path.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-3713?

2 open source packages ship an affected version, including angular-http-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `angular-http-server` | npm | All versions | 1.6.0 |
| `angular-http-server` | npm | All versions | 1.6.0 |

Products: Angular-Http-Server Project Angular-Http-Server.

## How do I fix CVE-2018-3713?

Upgrade angular-http-server to 1.6.0 or later.

## Is CVE-2018-3713 being exploited?

There is no known exploitation of CVE-2018-3713 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3713 and fix it if it is affected.

What it is: CVE-2018-3713 is a medium-severity path traversal vulnerability in HackerOne angular-http-server node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3713 in the wild and no public exploit code.

Affected packages and fixed versions:
- angular-http-server (npm): affected all versions; fixed in 1.6.0
- angular-http-server (npm): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3713/ (Markdown: https://insights.sbomify.com/CVE-2018-3713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3713
- OSV: https://osv.dev/vulnerability/CVE-2018-3713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3713/
Summaries are generated and may contain mistakes; the official description above is the record.
