{"answers":{"affected":"2 open source packages ship an affected version, including glance. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3715 in the wild and no public exploit code.","fix":"Upgrade glance to 3.0.4 or later.","what":"CVE-2018-3715 is a medium-severity path traversal vulnerability in HackerOne glance node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-3715 and fix it if it is affected.\n\nWhat it is: CVE-2018-3715 is a medium-severity path traversal vulnerability in HackerOne glance node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-3715 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- glance (npm): affected all versions; fixed in 3.0.4\n- glance (npm): affected all versions; fixed in 3.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3715/ (Markdown: https://insights.sbomify.com/CVE-2018-3715/index.md)","id":"CVE-2018-3715","markdown":"https://insights.sbomify.com/CVE-2018-3715/index.md","name":"CVE-2018-3715","record":{"aliases":["GHSA-2x4q-6jfv-8h9h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js image library","requires_auth":"low_privilege","summary":"A path traversal vulnerability in the glance Node.js module allows attackers to read arbitrary files from the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"glance","vendor":"glance_project"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"glance node module before 3.0.4 suffers from a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path Traversal in glance","id":"CVE-2018-3715","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Stored Cross-Site Scripting in simplehttpserver","id":"CVE-2018-3716"},"packages":[{"ecosystem":"npm","fixed":["3.0.4"],"introduced":["0"],"last_affected":[],"package":"glance","purl":null,"source":"GHSA-2x4q-6jfv-8h9h"},{"ecosystem":"npm","fixed":["3.0.4"],"introduced":["0"],"last_affected":[],"package":"glance","purl":"pkg:npm/glance","source":"GHSA-2x4q-6jfv-8h9h"}],"prev":{"headline":"Path Traversal in node-srv","id":"CVE-2018-3714"},"products":["glance node module"],"published":"2018-06-07","related":[{"cvss_score":9.3,"headline":"Path traversal in n/a","id":"CVE-2022-31546","kev_date_added":null,"published":"2022-07-11"},{"cvss_score":6.5,"headline":"Path traversal vulnerability in glance","id":"CVE-2022-25937","kev_date_added":null,"published":"2023-02-13"},{"cvss_score":6.1,"headline":"Cross-Site Scripting in glance","id":"CVE-2018-3748","kev_date_added":null,"published":"2018-07-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"A path traversal vulnerability in the glance Node.js module allows attackers to read arbitrary files from the server.","url":"https://insights.sbomify.com/CVE-2018-3715/"}