# CVE-2018-3716: Stored Cross-Site Scripting in simplehttpserver

> Attackers can execute arbitrary scripts in victim browsers via malicious file names in the simplehttpserver Node.js module.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-jrhj-2j3q-xf3v

## What is CVE-2018-3716?

CVE-2018-3716 is a medium-severity cross-site scripting vulnerability in HackerOne simplehttpserver node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

simplehttpserver node module suffers from a Cross-Site Scripting vulnerability to a lack of validation of file names.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-3716?

2 open source packages ship an affected version, including simplehttpserver. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplehttpserver` | npm | All versions | 0.1.0 |
| `simplehttpserver` | npm | All versions | 0.1.0 |

Products: Simplehttpserver Project Simplehttpserver.

## How do I fix CVE-2018-3716?

Upgrade simplehttpserver to 0.1.0 or later.

## Is CVE-2018-3716 being exploited?

There is no known exploitation of CVE-2018-3716 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne simplehttpserver node module

- [CVE-2018-3787](https://insights.sbomify.com/CVE-2018-3787/): simplehttpserver allows directory traversal and file listing (high 7.5)
- [CVE-2018-16478](https://insights.sbomify.com/CVE-2018-16478/): Path Traversal in simplehttpserver (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3716 and fix it if it is affected.

What it is: CVE-2018-3716 is a medium-severity cross-site scripting vulnerability in HackerOne simplehttpserver node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-3716 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplehttpserver (npm): affected all versions; fixed in 0.1.0
- simplehttpserver (npm): affected all versions; fixed in 0.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3716/ (Markdown: https://insights.sbomify.com/CVE-2018-3716/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3716
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3716
- OSV: https://osv.dev/vulnerability/CVE-2018-3716

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3716/
Summaries are generated and may contain mistakes; the official description above is the record.
