{"answers":{"affected":"2 open source packages ship an affected version, including connect. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3717 in the wild and no public exploit code.","fix":"Upgrade connect to 2.14.0 or later.","what":"CVE-2018-3717 is a medium-severity cross-site scripting vulnerability in HackerOne connect node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-3717 and fix it if it is affected.\n\nWhat it is: CVE-2018-3717 is a medium-severity cross-site scripting vulnerability in HackerOne connect node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-3717 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- connect (npm): affected all versions; fixed in 2.14.0\n- connect (npm): affected all versions; fixed in 2.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3717/ (Markdown: https://insights.sbomify.com/CVE-2018-3717/index.md)","id":"CVE-2018-3717","markdown":"https://insights.sbomify.com/CVE-2018-3717/index.md","name":"CVE-2018-3717","record":{"aliases":["CLSA-2026-1784596288","DEBIAN-CVE-2018-3717","GHSA-rch9-xh7r-mqgw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js connect module","requires_auth":"low_privilege","summary":"An XSS vulnerability in the connect Node.js module allows attackers to inject malicious scripts via unvalidated file inputs in the directory middleware.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"connect","vendor":"sencha"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"connect node module before 2.14.0 suffers from a Cross-Site Scripting (XSS) vulnerability due to a lack of validation of file in directory.js middleware.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting in connect","id":"CVE-2018-3717","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":3,"next":{"headline":"vercel/serve allows access to restricted files if filename is URL encoded.","id":"CVE-2018-3718"},"packages":[{"ecosystem":"npm","fixed":["2.14.0"],"introduced":["0"],"last_affected":[],"package":"connect","purl":null,"source":"GHSA-rch9-xh7r-mqgw"},{"ecosystem":"npm","fixed":["2.14.0"],"introduced":["0"],"last_affected":[],"package":"connect","purl":"pkg:npm/connect","source":"GHSA-rch9-xh7r-mqgw"}],"prev":{"headline":"Stored Cross-Site Scripting in simplehttpserver","id":"CVE-2018-3716"},"products":["connect node module"],"published":"2018-06-07","related":[{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2013-4691","kev_date_added":null,"published":"2019-12-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"An XSS vulnerability in the connect Node.js module allows attackers to inject malicious scripts via unvalidated file inputs in the directory middleware.","url":"https://insights.sbomify.com/CVE-2018-3717/"}