# CVE-2018-3717: Cross-Site Scripting in connect

> An XSS vulnerability in the connect Node.js module allows attackers to inject malicious scripts via unvalidated file inputs in the directory middleware.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** CLSA-2026-1784596288, DEBIAN-CVE-2018-3717, GHSA-rch9-xh7r-mqgw

## What is CVE-2018-3717?

CVE-2018-3717 is a medium-severity cross-site scripting vulnerability in HackerOne connect node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

connect node module before 2.14.0 suffers from a Cross-Site Scripting (XSS) vulnerability due to a lack of validation of file in directory.js middleware.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-3717?

2 open source packages ship an affected version, including connect. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `connect` | npm | All versions | 2.14.0 |
| `connect` | npm | All versions | 2.14.0 |

Products: Sencha Connect.

## How do I fix CVE-2018-3717?

Upgrade connect to 2.14.0 or later.

## Is CVE-2018-3717 being exploited?

There is no known exploitation of CVE-2018-3717 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne connect node module

- [CVE-2013-4691](https://insights.sbomify.com/CVE-2013-4691/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3717 and fix it if it is affected.

What it is: CVE-2018-3717 is a medium-severity cross-site scripting vulnerability in HackerOne connect node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-3717 in the wild and no public exploit code.

Affected packages and fixed versions:
- connect (npm): affected all versions; fixed in 2.14.0
- connect (npm): affected all versions; fixed in 2.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3717/ (Markdown: https://insights.sbomify.com/CVE-2018-3717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3717
- OSV: https://osv.dev/vulnerability/CVE-2018-3717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3717/
Summaries are generated and may contain mistakes; the official description above is the record.
