# CVE-2018-3720: Prototype Pollution in assign-deep

> A prototype pollution vulnerability in the assign-deep library allows attackers to modify Object prototypes, affecting all objects in the application.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-xcvv-84j5-jw9h

## What is CVE-2018-3720?

CVE-2018-3720 is a high-severity vulnerability in HackerOne assign-deep node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

assign-deep node module before 0.4.7 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.

Weakness: CWE-471 (Modification of Assumed-Immutable Data (MAID))

## Which versions are affected by CVE-2018-3720?

2 open source packages ship an affected version, including assign-deep. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `assign-deep` | npm | All versions | 0.4.7 |
| `assign-deep` | npm | All versions | 0.4.7 |

Products: Assign-Deep Project Assign-Deep.

## How do I fix CVE-2018-3720?

Upgrade assign-deep to 0.4.7 or later.

## Is CVE-2018-3720 being exploited?

There is no known exploitation of CVE-2018-3720 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne assign-deep node module

- [CVE-2019-10745](https://insights.sbomify.com/CVE-2019-10745/): assign-deep Vulnerable to Prototype Pollution (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3720 and fix it if it is affected.

What it is: CVE-2018-3720 is a high-severity vulnerability in HackerOne assign-deep node module, published on 7 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3720 in the wild and no public exploit code.

Affected packages and fixed versions:
- assign-deep (npm): affected all versions; fixed in 0.4.7
- assign-deep (npm): affected all versions; fixed in 0.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3720/ (Markdown: https://insights.sbomify.com/CVE-2018-3720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3720
- OSV: https://osv.dev/vulnerability/CVE-2018-3720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3720/
Summaries are generated and may contain mistakes; the official description above is the record.
