# CVE-2018-3721: Prototype Pollution in lodash


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** AZL-45420, CLSA-2026-1784250516, DEBIAN-CVE-2018-3721, GHSA-fvqr-27wr-82fm, MINI-37hp-76jx-fhmg, MINI-rmc3-rxj3-xc2r, UBUNTU-CVE-2018-3721

## What is CVE-2018-3721?

CVE-2018-3721 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 7 Jun 2018. 

### Official description

lodash node module before 4.17.5 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability via defaultsDeep, merge, and mergeWith functions, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes), CWE-471 (Modification of Assumed-Immutable Data (MAID))

## Which versions are affected by CVE-2018-3721?

4 open source packages ship an affected version, including lodash-rails and lodash. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lodash-rails` | RubyGems | All versions | 4.17.5 |
| `lodash-rails` | RubyGems | All versions | 4.17.5 |
| `lodash` | npm | All versions | 4.17.5 |
| `lodash` | npm | All versions | 4.17.5 |

Products: Lodash Lodash, Netapp Active Iq Unified Manager, Netapp System Manager.

## How do I fix CVE-2018-3721?

Upgrade lodash-rails to 4.17.5 or later.

## Is CVE-2018-3721 being exploited?

There is no known exploitation of CVE-2018-3721 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2026-4800](https://insights.sbomify.com/CVE-2026-4800/): lodash vulnerable to Code Injection via `_.template` imports key names (high 8.1)
- [CVE-2020-8203](https://insights.sbomify.com/CVE-2020-8203/): Prototype Pollution in lodash (high 7.4)
- [CVE-2021-23337](https://insights.sbomify.com/CVE-2021-23337/): Command Injection (high 7.2)
- [CVE-2025-13465](https://insights.sbomify.com/CVE-2025-13465/): Prototype Pollution Vulnerability in Lodash _.unset and _.omit functions (medium 6.9)
- [CVE-2026-2950](https://insights.sbomify.com/CVE-2026-2950/): lodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit` (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3721 and fix it if it is affected.

What it is: CVE-2018-3721 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 7 Jun 2018. 
Exploitation: There is no known exploitation of CVE-2018-3721 in the wild and no public exploit code.

Affected packages and fixed versions:
- lodash-rails (RubyGems): affected all versions; fixed in 4.17.5
- lodash-rails (RubyGems): affected all versions; fixed in 4.17.5
- lodash (npm): affected all versions; fixed in 4.17.5
- lodash (npm): affected all versions; fixed in 4.17.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3721/ (Markdown: https://insights.sbomify.com/CVE-2018-3721/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3721
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3721
- OSV: https://osv.dev/vulnerability/CVE-2018-3721

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3721/
Summaries are generated and may contain mistakes; the official description above is the record.
