# CVE-2018-3722: Prototype Pollution in merge-deep


- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-9g9w-hmvj-5h57

## What is CVE-2018-3722?

CVE-2018-3722 is a high-severity vulnerability in HackerOne merge-deep node module, published on 7 Jun 2018. 

### Official description

merge-deep node module before 3.0.1 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.

Weakness: CWE-471 (Modification of Assumed-Immutable Data (MAID))

## Which versions are affected by CVE-2018-3722?

2 open source packages ship an affected version, including merge-deep. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `merge-deep` | npm | All versions | 3.0.1 |
| `merge-deep` | npm | All versions | 3.0.1 |

Products: Merge-Deep Project Merge-Deep.

## How do I fix CVE-2018-3722?

Upgrade merge-deep to 3.0.1 or later.

## Is CVE-2018-3722 being exploited?

There is no known exploitation of CVE-2018-3722 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne merge-deep node module

- [CVE-2021-26707](https://insights.sbomify.com/CVE-2021-26707/): Prototype pollution in Merge-deep (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3722 and fix it if it is affected.

What it is: CVE-2018-3722 is a high-severity vulnerability in HackerOne merge-deep node module, published on 7 Jun 2018. 
Exploitation: There is no known exploitation of CVE-2018-3722 in the wild and no public exploit code.

Affected packages and fixed versions:
- merge-deep (npm): affected all versions; fixed in 3.0.1
- merge-deep (npm): affected all versions; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3722/ (Markdown: https://insights.sbomify.com/CVE-2018-3722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3722
- OSV: https://osv.dev/vulnerability/CVE-2018-3722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3722/
Summaries are generated and may contain mistakes; the official description above is the record.
