CVE-2018-3728 Prototype Pollution in hoek
Attackers can modify Object prototypes via merge functions, potentially leading to data modification or code execution in applications using the hoek library.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-3728?
CVE-2018-3728 is a high-severity vulnerability in hapi hoek node module, published on 30 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
hoek node module before 4.2.0 and 5.0.x before 5.0.3 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability via 'merge' and 'applyToDefaults' functions, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.
Weakness: CWE-471
Which versions are affected by CVE-2018-3728?
4 open source packages ship an affected version, including hoek. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
hoek npm | All versions | 4.2.1 |
hoek npm | All versions | 4.2.1 |
hoek npm | From 5.0.0 | 5.0.3 |
hoek npm | From 5.0.0 | 5.0.3 |
Products include Hapijs Hoek.
How do I fix CVE-2018-3728?
Upgrade hoek to a fixed version for your release line: 4.2.1 or 5.0.3.
Is CVE-2018-3728 being exploited?
There is no known exploitation of CVE-2018-3728 in the wild and no public exploit code.
Other vulnerabilities in hapi hoek node module
Sources
Also known as DEBIAN-CVE-2018-3728, GHSA-jp4x-w63m-7wgm, UBUNTU-CVE-2018-3728.