# CVE-2018-3728: Prototype Pollution in hoek

> Attackers can modify Object prototypes via merge functions, potentially leading to data modification or code execution in applications using the hoek library.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-3728, GHSA-jp4x-w63m-7wgm, UBUNTU-CVE-2018-3728

## What is CVE-2018-3728?

CVE-2018-3728 is a high-severity vulnerability in hapi hoek node module, published on 30 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

hoek node module before 4.2.0 and 5.0.x before 5.0.3 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability via 'merge' and 'applyToDefaults' functions, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.

Weakness: CWE-471 (Modification of Assumed-Immutable Data (MAID))

## Which versions are affected by CVE-2018-3728?

4 open source packages ship an affected version, including hoek. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hoek` | npm | All versions | 4.2.1 |
| `hoek` | npm | All versions | 4.2.1 |
| `hoek` | npm | From 5.0.0 | 5.0.3 |
| `hoek` | npm | From 5.0.0 | 5.0.3 |

Products: Hapijs Hoek.

## How do I fix CVE-2018-3728?

Upgrade hoek to a fixed version for your release line: 4.2.1 or 5.0.3.

## Is CVE-2018-3728 being exploited?

There is no known exploitation of CVE-2018-3728 in the wild and no public exploit code.

## Other vulnerabilities in hapi hoek node module

- [CVE-2020-36604](https://insights.sbomify.com/CVE-2020-36604/): hoek subject to prototype pollution via the clone function. (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3728 and fix it if it is affected.

What it is: CVE-2018-3728 is a high-severity vulnerability in hapi hoek node module, published on 30 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3728 in the wild and no public exploit code.

Affected packages and fixed versions:
- hoek (npm): affected all versions; fixed in 4.2.1
- hoek (npm): affected all versions; fixed in 4.2.1
- hoek (npm): affected from 5.0.0; fixed in 5.0.3
- hoek (npm): affected from 5.0.0; fixed in 5.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3728/ (Markdown: https://insights.sbomify.com/CVE-2018-3728/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3728
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3728
- OSV: https://osv.dev/vulnerability/CVE-2018-3728

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3728/
Summaries are generated and may contain mistakes; the official description above is the record.
