{"answers":{"affected":"2 open source packages ship an affected version, including localhost-now. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3729 in the wild and no public exploit code.","fix":"Upgrade localhost-now to 1.0.2 or later.","what":"CVE-2018-3729 is a high-severity path traversal vulnerability in HackerOne localhost-now node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-3729 and fix it if it is affected.\n\nWhat it is: CVE-2018-3729 is a high-severity path traversal vulnerability in HackerOne localhost-now node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-3729 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- localhost-now (npm): affected all versions; fixed in 1.0.2\n- localhost-now (npm): affected all versions; fixed in 1.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3729/ (Markdown: https://insights.sbomify.com/CVE-2018-3729/index.md)","id":"CVE-2018-3729","markdown":"https://insights.sbomify.com/CVE-2018-3729/index.md","name":"CVE-2018-3729","record":{"aliases":["GHSA-2gjg-5x33-mmp2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js localhost-now module","requires_auth":"none","summary":"A path traversal vulnerability in the localhost-now Node.js module allows attackers to read arbitrary files with known paths.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"localhost-now","vendor":"localhost-now_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"localhost-now node module suffers from a Path Traversal vulnerability due to lack of validation of file, which allows a malicious user to read content of any file with known path.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path Traversal in localhost-now","id":"CVE-2018-3729","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Path Traversal in mcstatic","id":"CVE-2018-3730"},"packages":[{"ecosystem":"npm","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"localhost-now","purl":null,"source":"GHSA-2gjg-5x33-mmp2"},{"ecosystem":"npm","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"localhost-now","purl":"pkg:npm/localhost-now","source":"GHSA-2gjg-5x33-mmp2"}],"prev":{"headline":"Prototype Pollution in hoek","id":"CVE-2018-3728"},"products":["localhost-now node module"],"published":"2018-06-07","related":[{"cvss_score":7.5,"headline":"Path Traversal in localhost-now","id":"CVE-2019-5416","kev_date_added":null,"published":"2019-03-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"A path traversal vulnerability in the localhost-now Node.js module allows attackers to read arbitrary files with known paths.","url":"https://insights.sbomify.com/CVE-2018-3729/"}