# CVE-2018-3733: Path Traversal in crud-file-server

> A path traversal vulnerability in the crud-file-server Node.js module allows attackers to read arbitrary files from the server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-vfp9-gwrh-wq9g

## What is CVE-2018-3733?

CVE-2018-3733 is a high-severity path traversal vulnerability in HackerOne crud-file-server node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

crud-file-server node module before 0.9.0 suffers from a Path Traversal vulnerability due to incorrect validation of url, which allows a malicious user to read content of any file with known path.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-3733?

2 open source packages ship an affected version, including crud-file-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `crud-file-server` | npm | All versions | 0.9.0 |
| `crud-file-server` | npm | All versions | 0.9.0 |

Products: Crud-File-Server Project Crud-File-Server.

## How do I fix CVE-2018-3733?

Upgrade crud-file-server to 0.9.0 or later.

## Is CVE-2018-3733 being exploited?

There is no known exploitation of CVE-2018-3733 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne crud-file-server node module

- [CVE-2018-3726](https://insights.sbomify.com/CVE-2018-3726/): Cross-site Scripting (XSS) - Stored in crud-file-server (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3733 and fix it if it is affected.

What it is: CVE-2018-3733 is a high-severity path traversal vulnerability in HackerOne crud-file-server node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3733 in the wild and no public exploit code.

Affected packages and fixed versions:
- crud-file-server (npm): affected all versions; fixed in 0.9.0
- crud-file-server (npm): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3733/ (Markdown: https://insights.sbomify.com/CVE-2018-3733/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3733
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3733
- OSV: https://osv.dev/vulnerability/CVE-2018-3733

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3733/
Summaries are generated and may contain mistakes; the official description above is the record.
