# CVE-2018-3737: Regular Expression Denial of Service in sshpk

> Attackers can cause denial of service in applications using sshpk by providing crafted invalid public keys that trigger excessive CPU usage.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-3737, GHSA-2m39-62fm-q8r3, UBUNTU-CVE-2018-3737

## What is CVE-2018-3737?

CVE-2018-3737 is a high-severity denial of service vulnerability in HackerOne sshpk node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

sshpk is vulnerable to ReDoS when parsing crafted invalid public keys.

Weakness: CWE-185 (Incorrect Regular Expression), CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2018-3737?

2 open source packages ship an affected version, including sshpk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sshpk` | npm | All versions | 1.13.2 |
| `sshpk` | npm | All versions | 1.13.2 |

Products: Joyent Sshpk.

## How do I fix CVE-2018-3737?

Upgrade sshpk to 1.13.2 or later.

## Is CVE-2018-3737 being exploited?

There is no known exploitation of CVE-2018-3737 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3737 and fix it if it is affected.

What it is: CVE-2018-3737 is a high-severity denial of service vulnerability in HackerOne sshpk node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3737 in the wild and no public exploit code.

Affected packages and fixed versions:
- sshpk (npm): affected all versions; fixed in 1.13.2
- sshpk (npm): affected all versions; fixed in 1.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3737/ (Markdown: https://insights.sbomify.com/CVE-2018-3737/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3737
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3737
- OSV: https://osv.dev/vulnerability/CVE-2018-3737

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3737/
Summaries are generated and may contain mistakes; the official description above is the record.
