{"answers":{"affected":"2 open source packages ship an affected version, including https-proxy-agent. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3739 in the wild and no public exploit code.","fix":"Upgrade https-proxy-agent to 2.2.0 or later.","what":"CVE-2018-3739 is a critical denial of service vulnerability in HackerOne https-proxy-agent node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-3739 and fix it if it is affected.\n\nWhat it is: CVE-2018-3739 is a critical denial of service vulnerability in HackerOne https-proxy-agent node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-3739 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- https-proxy-agent (npm): affected all versions; fixed in 2.2.0\n- https-proxy-agent (npm): affected all versions; fixed in 2.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3739/ (Markdown: https://insights.sbomify.com/CVE-2018-3739/index.md)","id":"CVE-2018-3739","markdown":"https://insights.sbomify.com/CVE-2018-3739/index.md","name":"CVE-2018-3739","record":{"aliases":["CLSA-2026-1776904630","CVE-2018-3736","GHSA-8g7p-74h8-hg48"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js proxy agent","requires_auth":"none","summary":"Attackers can cause denial of service and leak uninitialized memory by submitting typed input to the auth parameter in https-proxy-agent.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"https-proxy-agent","vendor":"https-proxy-agent_project"}],"cvss":{"score":9.1,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"https-proxy-agent before 2.1.1 passes auth option to the Buffer constructor without proper sanitization, resulting in DoS and uninitialized memory leak in setups where an attacker could submit typed input to the 'auth' parameter (e.g. JSON).","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in https-proxy-agent","id":"CVE-2018-3739","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Sanitize vulnerable to Improper Input Validation and Cross-site Scripting","id":"CVE-2018-3740"},"packages":[{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"https-proxy-agent","purl":null,"source":"GHSA-8g7p-74h8-hg48"},{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"https-proxy-agent","purl":"pkg:npm/https-proxy-agent","source":"GHSA-8g7p-74h8-hg48"}],"prev":{"headline":"Denial of Service in protobufjs","id":"CVE-2018-3738"},"products":["https-proxy-agent node module"],"published":"2018-06-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can cause denial of service and leak uninitialized memory by submitting typed input to the auth parameter in https-proxy-agent.","url":"https://insights.sbomify.com/CVE-2018-3739/"}