{"answers":{"affected":"2 open source packages ship an affected version, including sanitize. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3740 in the wild and no public exploit code.","fix":"Upgrade sanitize to 4.6.3 or later.","what":"CVE-2018-3740 is a high-severity cross-site scripting vulnerability in Ryan Grove sanitize (ruby gem), published on 30 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-3740 and fix it if it is affected.\n\nWhat it is: CVE-2018-3740 is a high-severity cross-site scripting vulnerability in Ryan Grove sanitize (ruby gem), published on 30 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-3740 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sanitize (RubyGems): affected from 3.0.0; fixed in 4.6.3\n- sanitize (RubyGems): affected from 3.0.0; fixed in 4.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3740/ (Markdown: https://insights.sbomify.com/CVE-2018-3740/index.md)","id":"CVE-2018-3740","markdown":"https://insights.sbomify.com/CVE-2018-3740/index.md","name":"CVE-2018-3740","record":{"aliases":["DEBIAN-CVE-2018-3740","DSA-4358-1","GHSA-7f42-p84j-f58p","UBUNTU-CVE-2018-3740"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Sanitize gem","requires_auth":"none","summary":"Attackers can inject malicious scripts via crafted HTML fragments due to improper attribute sanitization in the Ruby Sanitize gem.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"sanitize","vendor":"sanitize_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A specially crafted HTML fragment can cause Sanitize gem for Ruby to allow non-whitelisted attributes to be used on a whitelisted HTML element.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sanitize vulnerable to Improper Input Validation and Cross-site Scripting","id":"CVE-2018-3740","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":4,"next":{"headline":"rails-html-sanitizer Cross-site Scripting vulnerability","id":"CVE-2018-3741"},"packages":[{"ecosystem":"RubyGems","fixed":["4.6.3"],"introduced":["3.0.0"],"last_affected":[],"package":"sanitize","purl":null,"source":"GHSA-7f42-p84j-f58p"},{"ecosystem":"RubyGems","fixed":["4.6.3"],"introduced":["3.0.0"],"last_affected":[],"package":"sanitize","purl":"pkg:gem/sanitize","source":"GHSA-7f42-p84j-f58p"}],"prev":{"headline":"Denial of Service in https-proxy-agent","id":"CVE-2018-3739"},"products":["sanitize (ruby gem)"],"published":"2018-03-30","related":[{"cvss_score":7.3,"headline":"Cross-site Scripting in Sanitize","id":"CVE-2020-4054","kev_date_added":null,"published":"2020-06-16"},{"cvss_score":6.1,"headline":"Sanitize vulnerable to Cross-site Scripting via Improper neutralization of `noscript` element","id":"CVE-2023-23627","kev_date_added":null,"published":"2023-01-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Ryan Grove"]},"summary":"Attackers can inject malicious scripts via crafted HTML fragments due to improper attribute sanitization in the Ruby Sanitize gem.","url":"https://insights.sbomify.com/CVE-2018-3740/"}