# CVE-2018-3740: Sanitize vulnerable to Improper Input Validation and Cross-site Scripting

> Attackers can inject malicious scripts via crafted HTML fragments due to improper attribute sanitization in the Ruby Sanitize gem.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-3740, DSA-4358-1, GHSA-7f42-p84j-f58p, UBUNTU-CVE-2018-3740

## What is CVE-2018-3740?

CVE-2018-3740 is a high-severity cross-site scripting vulnerability in Ryan Grove sanitize (ruby gem), published on 30 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A specially crafted HTML fragment can cause Sanitize gem for Ruby to allow non-whitelisted attributes to be used on a whitelisted HTML element.

Weakness: CWE-20 (Improper Input Validation), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-3740?

2 open source packages ship an affected version, including sanitize. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanitize` | RubyGems | From 3.0.0 | 4.6.3 |
| `sanitize` | RubyGems | From 3.0.0 | 4.6.3 |

Products: Sanitize Project Sanitize.

## How do I fix CVE-2018-3740?

Upgrade sanitize to 4.6.3 or later.

## Is CVE-2018-3740 being exploited?

There is no known exploitation of CVE-2018-3740 in the wild and no public exploit code.

## Other vulnerabilities in Ryan Grove sanitize (ruby gem)

- [CVE-2020-4054](https://insights.sbomify.com/CVE-2020-4054/): Cross-site Scripting in Sanitize (high 7.3)
- [CVE-2023-23627](https://insights.sbomify.com/CVE-2023-23627/): Sanitize vulnerable to Cross-site Scripting via Improper neutralization of `noscript` element (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3740 and fix it if it is affected.

What it is: CVE-2018-3740 is a high-severity cross-site scripting vulnerability in Ryan Grove sanitize (ruby gem), published on 30 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3740 in the wild and no public exploit code.

Affected packages and fixed versions:
- sanitize (RubyGems): affected from 3.0.0; fixed in 4.6.3
- sanitize (RubyGems): affected from 3.0.0; fixed in 4.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3740/ (Markdown: https://insights.sbomify.com/CVE-2018-3740/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3740
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3740
- OSV: https://osv.dev/vulnerability/CVE-2018-3740

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3740/
Summaries are generated and may contain mistakes; the official description above is the record.
