{"answers":{"affected":"2 open source packages ship an affected version, including rails-html-sanitizer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3741 in the wild and no public exploit code.","fix":"Upgrade rails-html-sanitizer to 1.0.4 or later.","what":"CVE-2018-3741 is a medium-severity cross-site scripting vulnerability in rails-html-sanitizer, published on 30 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-3741 and fix it if it is affected.\n\nWhat it is: CVE-2018-3741 is a medium-severity cross-site scripting vulnerability in rails-html-sanitizer, published on 30 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-3741 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.0.4\n- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3741/ (Markdown: https://insights.sbomify.com/CVE-2018-3741/index.md)","id":"CVE-2018-3741","markdown":"https://insights.sbomify.com/CVE-2018-3741/index.md","name":"CVE-2018-3741","record":{"aliases":["DEBIAN-CVE-2018-3741","GHSA-px3r-jm9g-c8w8","SUSE-SU-2019:2182-1","UBUNTU-CVE-2018-3741"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby HTML sanitizer","requires_auth":"none","summary":"Attackers can inject malicious scripts via specially-crafted HTML fragments in applications using the vulnerable Ruby sanitizer gem.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"html_sanitizer","vendor":"rubyonrails"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"There is a possible XSS vulnerability in all rails-html-sanitizer gem versions below 1.0.4 for Ruby. The gem allows non-whitelisted attributes to be present in sanitized output when input with specially-crafted HTML fragments, and these attributes can lead to an XSS attack on target applications. This issue is similar to CVE-2018-8048 in Loofah. All users running an affected release should either upgrade or use one of the workarounds immediately.","ecosystems":["RubyGems","SUSE:Enterprise Storage 4","SUSE:OpenStack Cloud 7","SUSE:OpenStack Cloud Crowbar 8","SUSE:OpenStack Cloud Crowbar 9"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"rails-html-sanitizer Cross-site Scripting vulnerability","id":"CVE-2018-3741","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":6,"n_references":1,"next":{"headline":"Open Redirect in hekto","id":"CVE-2018-3743"},"packages":[{"ecosystem":"RubyGems","fixed":["1.0.4"],"introduced":["0"],"last_affected":[],"package":"rails-html-sanitizer","purl":null,"source":"GHSA-px3r-jm9g-c8w8"},{"ecosystem":"RubyGems","fixed":["1.0.4"],"introduced":["0"],"last_affected":[],"package":"rails-html-sanitizer","purl":"pkg:gem/rails-html-sanitizer","source":"GHSA-px3r-jm9g-c8w8"},{"ecosystem":"SUSE:Enterprise Storage 4","fixed":["1.0.3-8.8.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-rails-html-sanitizer","purl":"pkg:rpm/suse/rubygem-rails-html-sanitizer\u0026distro=SUSE%20Enterprise%20Storage%204","source":"SUSE-SU-2019:2182-1"},{"ecosystem":"SUSE:OpenStack Cloud 7","fixed":["1.0.3-8.8.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-rails-html-sanitizer","purl":"pkg:rpm/suse/rubygem-rails-html-sanitizer\u0026distro=SUSE%20OpenStack%20Cloud%207","source":"SUSE-SU-2019:2182-1"},{"ecosystem":"SUSE:OpenStack Cloud Crowbar 8","fixed":["1.0.3-8.8.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-rails-html-sanitizer","purl":"pkg:rpm/suse/rubygem-rails-html-sanitizer\u0026distro=SUSE%20OpenStack%20Cloud%20Crowbar%208","source":"SUSE-SU-2019:2182-1"},{"ecosystem":"SUSE:OpenStack Cloud Crowbar 9","fixed":["1.0.3-8.8.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-rails-html-sanitizer","purl":"pkg:rpm/suse/rubygem-rails-html-sanitizer\u0026distro=SUSE%20OpenStack%20Cloud%20Crowbar%209","source":"SUSE-SU-2019:2182-1"}],"prev":{"headline":"Sanitize vulnerable to Improper Input Validation and Cross-site Scripting","id":"CVE-2018-3740"},"products":["rails-html-sanitizer"],"published":"2018-03-30","related":[{"cvss_score":6.1,"headline":"rails-html-sanitizer Cross-site Scripting vulnerability","id":"CVE-2015-7578","kev_date_added":null,"published":"2016-02-16"},{"cvss_score":6.1,"headline":"rails-html-sanitizer Cross-site Scripting vulnerability","id":"CVE-2015-7579","kev_date_added":null,"published":"2016-02-16"},{"cvss_score":6.1,"headline":"rails-html-sanitizer Cross-site Scripting vulnerability","id":"CVE-2015-7580","kev_date_added":null,"published":"2016-02-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Rails"]},"summary":"Attackers can inject malicious scripts via specially-crafted HTML fragments in applications using the vulnerable Ruby sanitizer gem.","url":"https://insights.sbomify.com/CVE-2018-3741/"}