# CVE-2018-3741: rails-html-sanitizer Cross-site Scripting vulnerability

> Attackers can inject malicious scripts via specially-crafted HTML fragments in applications using the vulnerable Ruby sanitizer gem.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-3741, GHSA-px3r-jm9g-c8w8, SUSE-SU-2019:2182-1, UBUNTU-CVE-2018-3741

## What is CVE-2018-3741?

CVE-2018-3741 is a medium-severity cross-site scripting vulnerability in rails-html-sanitizer, published on 30 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

There is a possible XSS vulnerability in all rails-html-sanitizer gem versions below 1.0.4 for Ruby. The gem allows non-whitelisted attributes to be present in sanitized output when input with specially-crafted HTML fragments, and these attributes can lead to an XSS attack on target applications. This issue is similar to CVE-2018-8048 in Loofah. All users running an affected release should either upgrade or use one of the workarounds immediately.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-3741?

2 open source packages ship an affected version, including rails-html-sanitizer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails-html-sanitizer` | RubyGems | All versions | 1.0.4 |
| `rails-html-sanitizer` | RubyGems | All versions | 1.0.4 |
| `rubygem-rails-html-sanitizer` | SUSE:Enterprise Storage 4 | All versions | 1.0.3-8.8.1 |
| `rubygem-rails-html-sanitizer` | SUSE:OpenStack Cloud 7 | All versions | 1.0.3-8.8.1 |
| `rubygem-rails-html-sanitizer` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.0.3-8.8.1 |
| `rubygem-rails-html-sanitizer` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.0.3-8.8.1 |

Products: Rubyonrails Html Sanitizer.

## How do I fix CVE-2018-3741?

Upgrade rails-html-sanitizer to 1.0.4 or later.

## Is CVE-2018-3741 being exploited?

There is no known exploitation of CVE-2018-3741 in the wild and no public exploit code.

## Other vulnerabilities in rails-html-sanitizer

- [CVE-2015-7578](https://insights.sbomify.com/CVE-2015-7578/): rails-html-sanitizer Cross-site Scripting vulnerability (medium 6.1)
- [CVE-2015-7579](https://insights.sbomify.com/CVE-2015-7579/): rails-html-sanitizer Cross-site Scripting vulnerability (medium 6.1)
- [CVE-2015-7580](https://insights.sbomify.com/CVE-2015-7580/): rails-html-sanitizer Cross-site Scripting vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3741 and fix it if it is affected.

What it is: CVE-2018-3741 is a medium-severity cross-site scripting vulnerability in rails-html-sanitizer, published on 30 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-3741 in the wild and no public exploit code.

Affected packages and fixed versions:
- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.0.4
- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3741/ (Markdown: https://insights.sbomify.com/CVE-2018-3741/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3741
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3741
- OSV: https://osv.dev/vulnerability/CVE-2018-3741

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3741/
Summaries are generated and may contain mistakes; the official description above is the record.
