CVE-2018-3746 Command Injection in pdfinfojs

Critical 9.8 Published Updated

Attackers can execute arbitrary commands on the victim's machine via the pdfinfojs NPM module.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-3746?

CVE-2018-3746 is a critical command injection vulnerability in HackerOne pdfinfojs, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The pdfinfojs NPM module versions <= 0.3.6 has a command injection vulnerability that allows an attacker to execute arbitrary commands on the victim's machine.

Weakness: CWE-78, CWE-77

Which versions are affected by CVE-2018-3746?

2 open source packages ship an affected version, including pdfinfojs. It affects 1 product.

PackageAffectedFixed in
pdfinfojs npmAll versions0.4.1
pdfinfojs npmAll versions0.4.1

Products include Pdfinfojs Project Pdfinfojs.

How do I fix CVE-2018-3746?

Upgrade pdfinfojs to 0.4.1 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2018-3746 being exploited?

There is no known exploitation of CVE-2018-3746 in the wild and no public exploit code.

Sources

Also known as GHSA-3pxp-6963-46r9.

Is CVE-2018-3746 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free