# CVE-2018-3746: Command Injection in pdfinfojs

> Attackers can execute arbitrary commands on the victim's machine via the pdfinfojs NPM module.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-3pxp-6963-46r9

## What is CVE-2018-3746?

CVE-2018-3746 is a critical command injection vulnerability in HackerOne pdfinfojs, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The pdfinfojs NPM module versions <= 0.3.6 has a command injection vulnerability that allows an attacker to execute arbitrary commands on the victim's machine.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2018-3746?

2 open source packages ship an affected version, including pdfinfojs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pdfinfojs` | npm | All versions | 0.4.1 |
| `pdfinfojs` | npm | All versions | 0.4.1 |

Products: Pdfinfojs Project Pdfinfojs.

## How do I fix CVE-2018-3746?

Upgrade pdfinfojs to 0.4.1 or later.

## Is CVE-2018-3746 being exploited?

There is no known exploitation of CVE-2018-3746 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3746 and fix it if it is affected.

What it is: CVE-2018-3746 is a critical command injection vulnerability in HackerOne pdfinfojs, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3746 in the wild and no public exploit code.

Affected packages and fixed versions:
- pdfinfojs (npm): affected all versions; fixed in 0.4.1
- pdfinfojs (npm): affected all versions; fixed in 0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3746/ (Markdown: https://insights.sbomify.com/CVE-2018-3746/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3746
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3746
- OSV: https://osv.dev/vulnerability/CVE-2018-3746

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3746/
Summaries are generated and may contain mistakes; the official description above is the record.
