CVE-2018-3747 Cross-Site Scripting in public

Medium 6.1 Published Updated

Attackers can execute malicious JavaScript by embedding HTML in file names within the affected Node.js module.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2018-3747?

CVE-2018-3747 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The public node module versions <= 1.0.3 allows to embed HTML in file names, which (in certain conditions) might lead to execute malicious JavaScript.

Weakness: CWE-79

Which versions are affected by CVE-2018-3747?

2 open source packages ship an affected version, including public. It affects 1 product.

PackageAffectedFixed in
public npmAll versions0.1.4
public npmAll versions0.1.4

Products include Public.js Project Public.js.

How do I fix CVE-2018-3747?

Upgrade public to 0.1.4 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2018-3747 being exploited?

There is no known exploitation of CVE-2018-3747 in the wild and no public exploit code.

Sources

Also known as GHSA-8p5p-ff7x-hw7q.

Is CVE-2018-3747 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free