{"answers":{"affected":"2 open source packages ship an affected version, including public. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3747 in the wild and no public exploit code.","fix":"Upgrade public to 0.1.4 or later.","what":"CVE-2018-3747 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-3747 and fix it if it is affected.\n\nWhat it is: CVE-2018-3747 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-3747 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- public (npm): affected all versions; fixed in 0.1.4\n- public (npm): affected all versions; fixed in 0.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3747/ (Markdown: https://insights.sbomify.com/CVE-2018-3747/index.md)","id":"CVE-2018-3747","markdown":"https://insights.sbomify.com/CVE-2018-3747/index.md","name":"CVE-2018-3747","record":{"aliases":["GHSA-8p5p-ff7x-hw7q"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js file module","requires_auth":"none","summary":"Attackers can execute malicious JavaScript by embedding HTML in file names within the affected Node.js module.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"public.js","vendor":"public.js_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The public node module versions \u003c= 1.0.3 allows to embed HTML in file names, which (in certain conditions) might lead to execute malicious JavaScript.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting in public","id":"CVE-2018-3747","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-Site Scripting in glance","id":"CVE-2018-3748"},"packages":[{"ecosystem":"npm","fixed":["0.1.4"],"introduced":["0"],"last_affected":[],"package":"public","purl":null,"source":"GHSA-8p5p-ff7x-hw7q"},{"ecosystem":"npm","fixed":["0.1.4"],"introduced":["0"],"last_affected":[],"package":"public","purl":"pkg:npm/public","source":"GHSA-8p5p-ff7x-hw7q"}],"prev":{"headline":"Command Injection in pdfinfojs","id":"CVE-2018-3746"},"products":["n/a"],"published":"2018-07-03","related":[{"cvss_score":7.5,"headline":"Path Traversal in public","id":"CVE-2018-3731","kev_date_added":null,"published":"2018-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can execute malicious JavaScript by embedding HTML in file names within the affected Node.js module.","url":"https://insights.sbomify.com/CVE-2018-3747/"}