CVE-2018-3748 Cross-Site Scripting in glance

Medium 6.1 Published Updated

Stored XSS in the glance npm module allows attackers to execute JavaScript via crafted file names in directory listings.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2018-3748?

CVE-2018-3748 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

There is a Stored XSS vulnerability in the glance node module versions <= 3.0.5. File name, which contains malicious HTML (eg. embedded iframe element or javascript: pseudo-protocol handler in <a> element) allows to execute JavaScript code against any user who opens a directory listing containing such crafted file name.

Weakness: CWE-79

Which versions are affected by CVE-2018-3748?

2 open source packages ship an affected version, including glance. It affects 1 product.

PackageAffectedFixed in
glance npmAll versions3.0.8
glance npmAll versions3.0.8

Products include Glance Project Glance.

How do I fix CVE-2018-3748?

Upgrade glance to 3.0.8 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2018-3748 being exploited?

There is no known exploitation of CVE-2018-3748 in the wild and no public exploit code.

Sources

Also known as GHSA-7375-vjr2-3g7w.

Is CVE-2018-3748 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free