{"answers":{"affected":"2 open source packages ship an affected version, including deap. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3749 in the wild and no public exploit code.","fix":"Upgrade deap to 1.0.1 or later.","what":"CVE-2018-3749 is a critical code injection vulnerability in n/a, published on 3 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-3749 and fix it if it is affected.\n\nWhat it is: CVE-2018-3749 is a critical code injection vulnerability in n/a, published on 3 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-3749 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- deap (npm): affected all versions; fixed in 1.0.1\n- deap (npm): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3749/ (Markdown: https://insights.sbomify.com/CVE-2018-3749/index.md)","id":"CVE-2018-3749","markdown":"https://insights.sbomify.com/CVE-2018-3749/index.md","name":"CVE-2018-3749","record":{"aliases":["GHSA-xg47-r67p-vhv5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js utility library","requires_auth":"none","summary":"Attackers can modify the Object prototype via controlled input, potentially leading to arbitrary code execution or privilege escalation in applications using the deap module.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"deap","vendor":"deap_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The utilities function in all versions \u003c 1.0.1 of the deap node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in Deap","id":"CVE-2018-3749","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Prototype Pollution in deep-extend","id":"CVE-2018-3750"},"packages":[{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"deap","purl":null,"source":"GHSA-xg47-r67p-vhv5"},{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"deap","purl":"pkg:npm/deap","source":"GHSA-xg47-r67p-vhv5"}],"prev":{"headline":"Cross-Site Scripting in glance","id":"CVE-2018-3748"},"products":["n/a"],"published":"2018-07-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can modify the Object prototype via controlled input, potentially leading to arbitrary code execution or privilege escalation in applications using the deap module.","url":"https://insights.sbomify.com/CVE-2018-3749/"}