# CVE-2018-3750: Prototype Pollution in deep-extend

> Attackers can modify the Object prototype via the deep-extend library, potentially leading to code execution or privilege escalation in Node.js applications.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2018
- **Updated:** 17 Sep 2024
- **Also known as:** CLSA-2026-1774484512, DEBIAN-CVE-2018-3750, GHSA-hr2v-3952-633q, UBUNTU-CVE-2018-3750

## What is CVE-2018-3750?

CVE-2018-3750 is a critical code injection vulnerability in n/a, published on 3 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The utilities function in all versions <= 0.5.0 of the deep-extend node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-3750?

2 open source packages ship an affected version, including deep-extend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deep-extend` | npm | All versions | 0.5.1 |
| `deep-extend` | npm | All versions | 0.5.1 |

Products: Deep Extend Project Deep Extend.

## How do I fix CVE-2018-3750?

Upgrade deep-extend to 0.5.1 or later.

## Is CVE-2018-3750 being exploited?

There is no known exploitation of CVE-2018-3750 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3750 and fix it if it is affected.

What it is: CVE-2018-3750 is a critical code injection vulnerability in n/a, published on 3 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3750 in the wild and no public exploit code.

Affected packages and fixed versions:
- deep-extend (npm): affected all versions; fixed in 0.5.1
- deep-extend (npm): affected all versions; fixed in 0.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3750/ (Markdown: https://insights.sbomify.com/CVE-2018-3750/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3750
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3750
- OSV: https://osv.dev/vulnerability/CVE-2018-3750

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3750/
Summaries are generated and may contain mistakes; the official description above is the record.
