{"answers":{"affected":"2 open source packages ship an affected version, including pdf-image. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3757 in the wild and no public exploit code.","fix":"Upgrade pdf-image to 2.0.0 or later.","what":"CVE-2018-3757 is a critical command injection vulnerability in n/a, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-3757 and fix it if it is affected.\n\nWhat it is: CVE-2018-3757 is a critical command injection vulnerability in n/a, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-3757 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pdf-image (npm): affected all versions; fixed in 2.0.0\n- pdf-image (npm): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3757/ (Markdown: https://insights.sbomify.com/CVE-2018-3757/index.md)","id":"CVE-2018-3757","markdown":"https://insights.sbomify.com/CVE-2018-3757/index.md","name":"CVE-2018-3757","record":{"aliases":["GHSA-5gwh-g79j-vh4q"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js image library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via unescaped parameters in the pdf-image library, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"pdf-image","vendor":"pdf-image_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Command injection exists in pdf-image v2.0.0 due to an unescaped string parameter.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection in pdf-image","id":"CVE-2018-3757","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"express-cart unrestricted file upload vulnerability","id":"CVE-2018-3758"},"packages":[{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"pdf-image","purl":null,"source":"GHSA-5gwh-g79j-vh4q"},{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"pdf-image","purl":"pkg:npm/pdf-image","source":"GHSA-5gwh-g79j-vh4q"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2018-3756"},"products":["n/a"],"published":"2018-06-01","related":[{"cvss_score":9.8,"headline":"pdf-image has an OS Command Injection Vulnerability through its pdfFilePath parameter","id":"CVE-2026-26830","kev_date_added":null,"published":"2026-03-25"},{"cvss_score":9.8,"headline":"Improper Input Validation and Code Injection in pdf-image","id":"CVE-2020-8132","kev_date_added":null,"published":"2020-02-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via unescaped parameters in the pdf-image library, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2018-3757/"}