# CVE-2018-3757: Command Injection in pdf-image

> Attackers can execute arbitrary commands via unescaped parameters in the pdf-image library, requiring an upgrade to mitigate.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-5gwh-g79j-vh4q

## What is CVE-2018-3757?

CVE-2018-3757 is a critical command injection vulnerability in n/a, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Command injection exists in pdf-image v2.0.0 due to an unescaped string parameter.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2018-3757?

2 open source packages ship an affected version, including pdf-image. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pdf-image` | npm | All versions | 2.0.0 |
| `pdf-image` | npm | All versions | 2.0.0 |

Products: Pdf-Image Project Pdf-Image.

## How do I fix CVE-2018-3757?

Upgrade pdf-image to 2.0.0 or later.

## Is CVE-2018-3757 being exploited?

There is no known exploitation of CVE-2018-3757 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-26830](https://insights.sbomify.com/CVE-2026-26830/): pdf-image has an OS Command Injection Vulnerability through its pdfFilePath parameter (critical 9.8)
- [CVE-2020-8132](https://insights.sbomify.com/CVE-2020-8132/): Improper Input Validation and Code Injection in pdf-image (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3757 and fix it if it is affected.

What it is: CVE-2018-3757 is a critical command injection vulnerability in n/a, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3757 in the wild and no public exploit code.

Affected packages and fixed versions:
- pdf-image (npm): affected all versions; fixed in 2.0.0
- pdf-image (npm): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3757/ (Markdown: https://insights.sbomify.com/CVE-2018-3757/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3757
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3757
- OSV: https://osv.dev/vulnerability/CVE-2018-3757

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3757/
Summaries are generated and may contain mistakes; the official description above is the record.
