{"answers":{"affected":"2 open source packages ship an affected version, including express-cart. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3758 in the wild and no public exploit code.","fix":"Upgrade express-cart to 1.1.7 or later.","what":"CVE-2018-3758 is a high-severity vulnerability in HackerOne express-cart, published on 7 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-3758 and fix it if it is affected.\n\nWhat it is: CVE-2018-3758 is a high-severity vulnerability in HackerOne express-cart, published on 7 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-3758 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- express-cart (npm): affected all versions; fixed in 1.1.7\n- express-cart (npm): affected all versions; fixed in 1.1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3758/ (Markdown: https://insights.sbomify.com/CVE-2018-3758/index.md)","id":"CVE-2018-3758","markdown":"https://insights.sbomify.com/CVE-2018-3758/index.md","name":"CVE-2018-3758","record":{"aliases":["GHSA-4w62-cq5r-5mmq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js e-commerce library","requires_auth":"low_privilege","summary":"A privileged user can upload malicious files to execute arbitrary code on the hosting machine via the express-cart library.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"express-cart","vendor":"express-cart_project"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Unrestricted file upload (RCE) in express-cart module before 1.1.7 allows a privileged user to gain access in the hosting machine.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"express-cart unrestricted file upload vulnerability","id":"CVE-2018-3758","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"file_upload","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"private_address_check contains race condition","id":"CVE-2018-3759"},"packages":[{"ecosystem":"npm","fixed":["1.1.7"],"introduced":["0"],"last_affected":[],"package":"express-cart","purl":null,"source":"GHSA-4w62-cq5r-5mmq"},{"ecosystem":"npm","fixed":["1.1.7"],"introduced":["0"],"last_affected":[],"package":"express-cart","purl":"pkg:npm/express-cart","source":"GHSA-4w62-cq5r-5mmq"}],"prev":{"headline":"Command Injection in pdf-image","id":"CVE-2018-3757"},"products":["express-cart"],"published":"2018-06-07","related":[{"cvss_score":8.8,"headline":"Cross-Site Request Forgery in express-cart","id":"CVE-2020-22403","kev_date_added":null,"published":"2021-08-12"},{"cvss_score":8.8,"headline":"Authentication Bypass by Spoofing in express-cart","id":"CVE-2018-16483","kev_date_added":null,"published":"2019-02-01"},{"cvss_score":4.8,"headline":"Cross-site Scripting in express-cart","id":"CVE-2021-32573","kev_date_added":null,"published":"2021-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"A privileged user can upload malicious files to execute arbitrary code on the hosting machine via the express-cart library.","url":"https://insights.sbomify.com/CVE-2018-3758/"}