# CVE-2018-3770: Remote Code Execution in markdown-pdf

> An attacker can exploit a path traversal vulnerability in the markdown-pdf library to read arbitrary local files from the server.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-p7c9-jqhq-vr3v

## What is CVE-2018-3770?

CVE-2018-3770 is a medium-severity path traversal vulnerability in HackerOne markdown-pdf, published on 20 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A path traversal exists in markdown-pdf version <9.0.0 that allows a user to insert a malicious html code that can result in reading the local files.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-3770?

2 open source packages ship an affected version, including markdown-pdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `markdown-pdf` | npm | All versions | 9.0.0 |
| `markdown-pdf` | npm | All versions | 9.0.0 |

Products: Markdown-Pdf Project Markdown-Pdf.

## How do I fix CVE-2018-3770?

Upgrade markdown-pdf to 9.0.0 or later.

## Is CVE-2018-3770 being exploited?

There is no known exploitation of CVE-2018-3770 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne markdown-pdf

- [CVE-2023-0835](https://insights.sbomify.com/CVE-2023-0835/): markdown-pdf 11.0.0 - Local File Read via Server Side XSS (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3770 and fix it if it is affected.

What it is: CVE-2018-3770 is a medium-severity path traversal vulnerability in HackerOne markdown-pdf, published on 20 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3770 in the wild and no public exploit code.

Affected packages and fixed versions:
- markdown-pdf (npm): affected all versions; fixed in 9.0.0
- markdown-pdf (npm): affected all versions; fixed in 9.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3770/ (Markdown: https://insights.sbomify.com/CVE-2018-3770/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3770
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3770
- OSV: https://osv.dev/vulnerability/CVE-2018-3770

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3770/
Summaries are generated and may contain mistakes; the official description above is the record.
