{"answers":{"affected":"2 open source packages ship an affected version, including whereis. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3772 in the wild and no public exploit code.","fix":"Upgrade whereis to 0.4.1 or later.","what":"CVE-2018-3772 is a critical command injection vulnerability in https://github.com/vvo whereis, published on 30 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-3772 and fix it if it is affected.\n\nWhat it is: CVE-2018-3772 is a critical command injection vulnerability in https://github.com/vvo whereis, published on 30 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-3772 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- whereis (npm): affected all versions; fixed in 0.4.1\n- whereis (npm): affected all versions; fixed in 0.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3772/ (Markdown: https://insights.sbomify.com/CVE-2018-3772/index.md)","id":"CVE-2018-3772","markdown":"https://insights.sbomify.com/CVE-2018-3772/index.md","name":"CVE-2018-3772","record":{"aliases":["GHSA-wjr4-2jgw-hmv8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js whereis module","requires_auth":"none","summary":"Attackers can execute arbitrary commands via unsanitized input in the deprecated whereis npm module, requiring migration to the which module.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"whereis","vendor":"whereis_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"Concatenating unsanitized user input in the `whereis` npm module \u003c 0.4.1 allowed an attacker to execute arbitrary commands. The `whereis` module is deprecated and it is recommended to use the `which` npm module instead.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection in whereis","id":"CVE-2018-3772","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"metascraper before v5.2.0 vulnerable to stored cross-site scripting","id":"CVE-2018-3773"},"packages":[{"ecosystem":"npm","fixed":["0.4.1"],"introduced":["0"],"last_affected":[],"package":"whereis","purl":null,"source":"GHSA-wjr4-2jgw-hmv8"},{"ecosystem":"npm","fixed":["0.4.1"],"introduced":["0"],"last_affected":[],"package":"whereis","purl":"pkg:npm/whereis","source":"GHSA-wjr4-2jgw-hmv8"}],"prev":{"headline":"statics-server Cross-site Scripting vulnerability","id":"CVE-2018-3771"},"products":["whereis"],"published":"2018-07-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["https://github.com/vvo"]},"summary":"Attackers can execute arbitrary commands via unsanitized input in the deprecated whereis npm module, requiring migration to the which module.","url":"https://insights.sbomify.com/CVE-2018-3772/"}