# CVE-2018-3772: Command Injection in whereis

> Attackers can execute arbitrary commands via unsanitized input in the deprecated whereis npm module, requiring migration to the which module.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-wjr4-2jgw-hmv8

## What is CVE-2018-3772?

CVE-2018-3772 is a critical command injection vulnerability in https://github.com/vvo whereis, published on 30 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Concatenating unsanitized user input in the `whereis` npm module < 0.4.1 allowed an attacker to execute arbitrary commands. The `whereis` module is deprecated and it is recommended to use the `which` npm module instead.

Weakness: CWE-20 (Improper Input Validation), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2018-3772?

2 open source packages ship an affected version, including whereis. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `whereis` | npm | All versions | 0.4.1 |
| `whereis` | npm | All versions | 0.4.1 |

Products: Whereis Project Whereis.

## How do I fix CVE-2018-3772?

Upgrade whereis to 0.4.1 or later.

## Is CVE-2018-3772 being exploited?

There is no known exploitation of CVE-2018-3772 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-3772 and fix it if it is affected.

What it is: CVE-2018-3772 is a critical command injection vulnerability in https://github.com/vvo whereis, published on 30 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-3772 in the wild and no public exploit code.

Affected packages and fixed versions:
- whereis (npm): affected all versions; fixed in 0.4.1
- whereis (npm): affected all versions; fixed in 0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-3772/ (Markdown: https://insights.sbomify.com/CVE-2018-3772/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-3772
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-3772
- OSV: https://osv.dev/vulnerability/CVE-2018-3772

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-3772/
Summaries are generated and may contain mistakes; the official description above is the record.
