CVE-2018-3773 metascraper before v5.2.0 vulnerable to stored cross-site scripting

Medium 6.1 Published Updated

Stored Cross-Site Scripting in the metascraper npm module allows attackers to execute arbitrary scripts via Open Graph meta properties.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2018-3773?

CVE-2018-3773 is a medium-severity cross-site scripting vulnerability in https://github.com/microlinkhq metascraper, published on 30 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

There is a stored Cross-Site Scripting vulnerability in Open Graph meta properties read by the `metascrape` npm module <= 3.9.2.

Weakness: CWE-79

Which versions are affected by CVE-2018-3773?

2 open source packages ship an affected version, including metascraper. It affects 1 product.

PackageAffectedFixed in
metascraper npmAll versions5.2.0
metascraper npmAll versions5.2.0

Products include Metascraper Project Metascraper.

How do I fix CVE-2018-3773?

Upgrade metascraper to 5.2.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2018-3773 being exploited?

There is no known exploitation of CVE-2018-3773 in the wild and no public exploit code.

Sources

Also known as GHSA-8f64-q7jc-ccgp.

Is CVE-2018-3773 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free