{"answers":{"affected":"2 open source packages ship an affected version, including metascraper. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3773 in the wild and no public exploit code.","fix":"Upgrade metascraper to 5.2.0 or later.","what":"CVE-2018-3773 is a medium-severity cross-site scripting vulnerability in https://github.com/microlinkhq metascraper, published on 30 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-3773 and fix it if it is affected.\n\nWhat it is: CVE-2018-3773 is a medium-severity cross-site scripting vulnerability in https://github.com/microlinkhq metascraper, published on 30 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-3773 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- metascraper (npm): affected all versions; fixed in 5.2.0\n- metascraper (npm): affected all versions; fixed in 5.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3773/ (Markdown: https://insights.sbomify.com/CVE-2018-3773/index.md)","id":"CVE-2018-3773","markdown":"https://insights.sbomify.com/CVE-2018-3773/index.md","name":"CVE-2018-3773","record":{"aliases":["GHSA-8f64-q7jc-ccgp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"npm metascraper library","requires_auth":"none","summary":"Stored Cross-Site Scripting in the metascraper npm module allows attackers to execute arbitrary scripts via Open Graph meta properties.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"metascraper","vendor":"metascraper_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"There is a stored Cross-Site Scripting vulnerability in Open Graph meta properties read by the `metascrape` npm module \u003c= 3.9.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"metascraper before v5.2.0 vulnerable to stored cross-site scripting","id":"CVE-2018-3773","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Open Redirect in url-parse","id":"CVE-2018-3774"},"packages":[{"ecosystem":"npm","fixed":["5.2.0"],"introduced":["0"],"last_affected":[],"package":"metascraper","purl":null,"source":"GHSA-8f64-q7jc-ccgp"},{"ecosystem":"npm","fixed":["5.2.0"],"introduced":["0"],"last_affected":[],"package":"metascraper","purl":"pkg:npm/metascraper","source":"GHSA-8f64-q7jc-ccgp"}],"prev":{"headline":"Command Injection in whereis","id":"CVE-2018-3772"},"products":["metascraper"],"published":"2018-07-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["https://github.com/microlinkhq"]},"summary":"Stored Cross-Site Scripting in the metascraper npm module allows attackers to execute arbitrary scripts via Open Graph meta properties.","url":"https://insights.sbomify.com/CVE-2018-3773/"}