{"answers":{"affected":"2 open source packages ship an affected version, including restforce. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-3777 in the wild and no public exploit code.","fix":"Upgrade restforce to 3.0.0 or later.","what":"CVE-2018-3777 is a critical vulnerability in https://github.com/restforce restforce ruby gem, published on 3 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-3777 and fix it if it is affected.\n\nWhat it is: CVE-2018-3777 is a critical vulnerability in https://github.com/restforce restforce ruby gem, published on 3 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-3777 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- restforce (RubyGems): affected all versions; fixed in 3.0.0\n- restforce (RubyGems): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-3777/ (Markdown: https://insights.sbomify.com/CVE-2018-3777/index.md)","id":"CVE-2018-3777","markdown":"https://insights.sbomify.com/CVE-2018-3777/index.md","name":"CVE-2018-3777","record":{"aliases":["GHSA-534w-937m-v7x3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","other"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Salesforce API client","requires_auth":"none","summary":"Attackers can inject arbitrary parameters into Salesforce API requests due to insufficient URI encoding in the restforce Ruby gem.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"restforce","vendor":"restforce"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-172","name":"Improper Encoding or Decoding of Data"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Insufficient URI encoding in restforce before 3.0.0 allows attacker to inject arbitrary parameters into Salesforce API requests.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"restforce vulnerable to Improper Input Validation","id":"CVE-2018-3777","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"other","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Improper Authorization in aedes","id":"CVE-2018-3778"},"packages":[{"ecosystem":"RubyGems","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"restforce","purl":null,"source":"GHSA-534w-937m-v7x3"},{"ecosystem":"RubyGems","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"restforce","purl":"pkg:gem/restforce","source":"GHSA-534w-937m-v7x3"}],"prev":{"headline":"Information disclosure in Nextcloud Server","id":"CVE-2018-3776"},"products":["restforce ruby gem"],"published":"2018-08-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["https://github.com/restforce"]},"summary":"Attackers can inject arbitrary parameters into Salesforce API requests due to insufficient URI encoding in the restforce Ruby gem.","url":"https://insights.sbomify.com/CVE-2018-3777/"}